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About MicroGrade 
MicroGrade is a tool which automates the tasks of scoring assignments, calculating grades, and evaluating 
student performance.   

By using MicroGrade’s e-mail feature, professors can easily communicate progress to their students by e-
mailing messages and reports to any or all students with a confirming copy to the instructor. 

If you do not have your own class data to use for the following exercises, please open the e-mail sent to 
you earlier today and save the three class files where you can find them again (e.g., H:\docs).   

The file names are 09 MG class.txt, 09 Sample DataLink Scores.txt and 09 MG class.cls 
 
 

Set Up a Class (One-time Setup) 

Exercise #1 – Export a Class Roster from CedarInfo 

This step requires faculty access to class rosters. Just 
look over someone’s shoulder if you cannot retrieve a 
class roster. 

1. Use an Internet browser to go to the FacStaff 
Homepage.  

2. Click [CedarInfo] > Log in using your CedarNet 
username and password.   

3. Under Curricular Transactions > Choose Get a 
class roster 

4. Choose the appropriate term from the Term 
drop-down list. 

5. Type in the Subject, Course, and Section of 
one of your classes (see example at right). 

6. Under Format(s) to receive: first click the radio 
button labeled Files on my H drive. 

7. Then check MicroGrade text format [.txt] box. 

8. Click [Submit].  

9. A screen will appear indicating that a file with the 
subject, course number, and the .txt extension 
has been saved on your H: drive in the DOCS folder.                                                                                       
Make a note of the file name. 

10. Using My Computer or Windows Explorer, 
locate the .txt file you just created on your H: 
drive to verify that the steps executed correctly. 
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Exercise #2 – Import the Class Roster into MicroGrade 

Use the sample roster file named 09 MG class.txt to complete the following exercise. 

Open MicroGrade  

1. Click [Start] > All Programs > _CedarNet > Education > Select MicroGrade 6.0. 

(Click [Yes] if prompted. A Select MicroGrade File dialog box will open). 

Create a New Class 

2. Click [New Class]  

(A Creating a New Class dialog box will open). 

3. Choose [Experienced User] for these exercises (you can always choose [QuickStart] in the 
future if you wish to walk through the setup Wizard). 

4. (A new Untitled class will open in MicroGrade)  

Choose Students from the top grey menu bar > Choose Import Students… > Choose User 
Defined.... 

5. Navigate to where you saved the sample class roster file 09 MG class.txt (probably H:\docs). 

6. Choose the .txt file > Click [Open]. 

(A Select Import File Data Format box will appear. The first line is a file header which you can 
ignore. The second line should be your first student’s information.) 

7. Click the first student (2nd line) to select the student > Click [Continue…]. 

8. A Specify Import Fields dialog box will 
appear (see example at right).  Match the 
student information in the display window 
with a corresponding field in the MicroGrade 
Import Fields: drop-down list. 

9. Match the fields as indicated below: 
 

Highlight: Select: 

1132317 ID 

Carson Last Name 

Cammy First Name 

cammycarson E-mail 1 
 

(If you do not want to import a field, just 
leave it unmatched.) 

10. After you match all the fields you wish to 
import, click [OK].  

Important:  When you are prompted 
regarding automatic ID's, click [No].   

(Otherwise, you will replace the actual student ID's with random ID numbers generated by 
MicroGrade.)   

11. A message box will display indicating the import has been completed > Click [OK]. 

12. An Import Students Status dialog box will report how many students were processed. 

13. Click [Finished]. 
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(The student information will display in the upper left portion of the screen). 

14. To save your class, Click File > Select Save. 

15. Name the file (the name should include some reference to the class term and year; e.g., MG Class 
FA09). 

16. Navigate to where you wish to save the file > Click [Save].  

 

Exercise #3 – Add a Grading Period 

If you were unable to import the students using the 09 MG class.txt file in Exercise #2, you can use the 
09 MG Class.cls file that was sent to you before class to complete the following exercises. 

1. Choose Periods > Choose Add Grading Period... 
from the gray menu bar. 

2. The Add Grading Period dialog box will appear.  
Enter the term and year of your class (e.g., Fall 
2009) 

3. Type the Instructor Name and a complete E-
mail Address. 

Click the box labeled Copy Instructor on All Mail 
if you wish to receive a copy of sent e-mail. 

4. For the box labeled Student E-Mail Domain: type 
@cedarville.edu. 

5. Click the radio button labeled Use an SMTP 
Server: > Type mail.cedarville.edu. 

6. Ignore Code 1-4. 

7. Click [OK]. 

Note:  These settings will allow you to send e-mail 
directly from within the MicroGrade program without 
adding anything to the student usernames that you 
imported.   

Preferences 

You have the option of setting student names to display 
lastname, firstname according to your preference. 

1. Choose Edit > Choose Preferences For from 
the top menu bar. 

2. Choose Display and Sorting…. 
3. Under Display Options, click the radio button 

labeled Smith, Mary. 
4. Click [OK]. 

 

 

 

  

Setting Preferences 

1. Choose Edit from the grey menu bar > 
Select  Preferences For and then choose 
any of the following options: 

a. Display and Sorting… 
b. Reports… 
c. Grades and Scores… 
d. Student Information… 
e. Email… 

2. Make changes according to your 
preferences (or you may leave all defaults 
unchanged). 

3. Ignore the following options as they are 
not available with Micrograde at 
Cedarville: 

a. Web… 
b. Palm… 
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Exercise #4 – Set Up Categories, Assignments & Determining Weights 

What is a Category?  An Assignment? 

Set up a Category for each type of graded activity (e.g., Tests, Quizzes, Projects, Speeches, Papers, Final 
Exam, Midterm Exam, etc.) 

An Assignment is an individual activity within a Category.  

For example,  

• Category = Exams 

• Assignments = Exam 1, Exam 2, Exam 3 

Note:  Modify Categories and Assignments 
according to your preferences.  For example, a 
final exam may either be a separate category 
or an assignment within the Exam category 
according to how you wish to structure your 
class.  Use your existing syllabus as a starting 
point. 

 

Enter Categories 

For this exercise, set up your sample class with 
three categories:  Exams, Presentations, and Homework.   

In the following example: 

• All four exams combined are worth 60% of the overall grade and are individually worth 100 
points each.  You will drop the lowest exam score.   

• All 10 homework assignments are worth 25% of the total grade and are individually worth 10 
points each.   

• The presentation category is 15% and has one assignment worth 100 points.  

Instructions: 

1. From the gray menu bar of your new class, choose Edit > Choose Setup Categories... 

2. The Setup Categories, Assignments 
for Grading Period: __ dialog box will 
appear (The radio button labeled Add 
Categories should already be selected). 

3. For each new category, enter the 
category title, abbreviation, and 
overall percentage weight of the 
category toward the final grade. 

4. To indicate if this is a single assignment 
category, Click the Single Assignment 
Category checkbox. 

5. Click the Extra Credit Category 
checkbox to indicate an extra credit 
category. 

Note: Grades for assignments in an extra 
credit category will only be counted in 
the final grade if they will improve the student's final grade. Otherwise, they will be ignored. 

6. Indicate how many Low Scores to Drop (if any) from this category by entering a number in the 
associated box. 

How are Categories and Assignments weighted? 

You should consider categories and assignments 
independently when determining weights.   

The percentage weight for all the Categories combined 
should add up to 100% (and will determine the 
contribution to the final class grade).   

The Assignments within a given Category will combine 
automatically to make up 100% of that Category’s 
total weight. 
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7. Click [Enter] to create the category.  

8. Follow steps 3-7 (on the previous page) to add categories for the Exams, Presentations and 
Homework 
categories for 
this exercise. 

 

 

 

 

 

Enter Assignments 

1. Choose the Category for which you 
wish to enter assignments from the 
category display panel (e.g., Exams). 

2. Select the radio button labeled Add 
Assignments.   

3. Enter the assignment title (e.g., 
Exam 1). 

4. Next, enter up to a five-character 
abbreviation for the assignment                        
(e.g., EX1). 

5. Enter the maximum score possible 
(e.g., 100) and an optional due date.  

6. Click [Enter] to add the assignment 
information. 

7. Repeat steps 3-6 to add additional 
assignments for that category. 

8. To add assignments in a different category, repeat step one. 

Note:  It is recommended that you enter all assignments during your initial class setup, however; it 
is not required. Go back at any time to add more assignments. 

9. Click [OK] when you are finished entering all categories and assignments. 

 

Understand Views 

The MicroGrade screen can expand to four windows, as explained on the following page. 
  

You will see a running total of the Category percentages displayed in the left of the 
dialog box as Category Weights Total.  Make sure this total equals 100% after 
entering all categories. 

At any point, if any of these windows are not visible and you would like to 
display them, select Window from the gray menu bar and then select the 
window of your choice from the list.  

Choose Window then select Tile Windows to get the windows to display like 
illustrated on the next page. 
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This is the class Roster pane.  It lists your 
active students and displays the current 
cumulative grade for each.  

This is the student Summary window.  It displays 
grade details for the student whose name is 
highlighted in the Roster window (at left). 

The Cats&Assigns (Categories & 
Assignments) window shows the 
current grading status for each 
individual assignment. 

Finally, the class Scores window lists all students and their individual 
grades by assignment (no cumulative grades).   
To view a particular assignment, use the scroll bars or select the 
assignment name in the Cats&Assigns window (at left). 
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Maintain a Class 
 

Exercise #5 - Enter & Edit Scores 

We are going to enter scores for a few categories and assignments and view how MicroGrade 
automatically updates the cumulative grades.  You may use your own numbers for this exercise. 

Enter Scores 

Enter scores for Exam 1 and 2 for each 
student. 

1. Maximize the Scores Window. 

2. Locate the correct column for the 
first student > Enter his/her score. 

3. Click [Enter] to continue down the 
list. 

4. Repeat steps 2 and 3 until scores 
are entered for both exams for all 
students. 

 

 

 

 

 

 

 

 

Edit Scores 

Change Cammy’s Exam 1 score to an 87. 

5. To change a score, select a score 
and enter a new value.  

(An asterisk (*) will display next to 
the new score to indicate that it 
has been changed) 

 

6. Notice that a “d” displays next to 
the lowest score in the Exam 
category after you enter scores for 
at least two exams. 

 (This is only if you chose to drop 
the lowest score during the 
Category setup.)   

*Warning*:  If you enter a score in the wrong column, do not enter a “zero” or it will negatively 
affect the final grade.   

7. Click the incorrect score > Choose Scores > Choose Return to Unscored from the top menu. 

 

After you finish the entries, send the score window back to the lower right (Do not 
click the minimize button to do this. Click the maximize button again. Clicking 
minimize will completely minimize the window to the bottom of the screen).   

Notice that cumulative grades in the upper left are updated, and the grades for 
each individual student in the upper right are changed, plus the lower left window 
shows the assignment as being Fully Scored (only if you entered a score for each 
student, otherwise it will be Partially Scored). 
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Exercise #6 - Add and Drop Students 

 
For this exercise, we are going to add Eddy Edwards to our class and drop Billy Billings. 

1. From the top grey menu, choose 
Students  > Choose Students 
Records...  

2. The Edit Student Records 
dialog box will appear. 

 

Delete a Student 

*Warning* this will erase all scores 
and information related to this student! 

3. Select the radio button labeled 
Edit Active Students. 

4. Choose the student’s name in 
the left column (e.g., Billy 
Billings). 

5. Click [Drop] located near the 
bottom of the window. 

 

 
Add a Student 

6. Select the radio button labeled Add Students.  

7. Fill in the appropriate fields at the top of the page for Eddy Edwards. 

8. Delete the Student ID that MicroGrade automatically generated and fill in the Cedarville student 
ID number 8293041. 

9. Enter the student’s username eddyedwards in the E-mail 1: field. 

10. Click [Enter] located along the bottom of the window.  

11. Click [Finished] located at the bottom right of the window. 
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Additional Functions 
 

Send Grades to Students via E-mail 

Setup e-mail preferences  

1. Click Edit from the top grey menu. 

2. Under the Preferences For drop-down box choose 
Email…. 

3. Enter the correct options replacing your e-mail 
address in the Instructor E-mail Address: field                                              
(see example at right). 

Note:  the most common cause of e-mail failure is if 
Use Chariot’s E-mail delivery service is checked (by default) instead of Use an SMTP Server. 

4. Make sure the SMTP server option is enabled and type mail.cedarville.edu > Click [OK]. 

 
Send the Student Summary report 

These steps have been tested to ensure that each student only receives his/her individual grades, not the 
entire classes’ grades.   

Be very careful to follow these instructions exactly 
as you cannot retract e-mail in Micrograde! 

1. Choose Reports > Choose Student 
Summary… from the top menu bar. 

(The Student Summary Report for 
Grading Period: __ dialog box will open.) 

2. Click in the left pane to choose the 
Categories (e.g., Exams, Presentations, 
and/or Homework) that you wish to send. 

3. Click the radio button for One Student Per 
Page. 

4. Choose Current class from the drop-down 
list of Students To Print: 

 
 
Note:  If you would like to test these options before 
sending out the student grades, add yourself as a 
student to the class and enter grades for yourself.  
Then choose Your Selection and highlight Your 
Name in the drop-down box from the Students to 
Print: section. 

5. To continue to send e-mail to students, 
choose E-mail 1 from the drop-down box for 
Output to: . 

6. Click [OK]. 

The e-mail each student receives will look like this 
report (left). 
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At Risk Students 

You can use MicroGrade to highlight those students “at risk” by following these steps.  
1. With MicroGrade open, choose Edit from the top menu bar. 
2. Choose Preferences For > Choose   Display and 

Sorting…. 
3. The Display&Sort Options for Grading Period: __ 

dialog box will open. 
4. Choose the grade from the drop-down list at or below 

which you wish to highlight in red (e.g., D in this 
example). 

5. Click [OK] (When you look at any grades, everything 
at or below a D will now display in red).  

 

Import Test Scores from DataLink 

You will need to ask the students to mark their ID number on the AppScan test form in order to upload 
scores to Micrograde from DataLink.  Save your AppScan scores as a .txt file.   
You can use the file that was sent to you before class 09 Sample DataLink Scores.txt to give these 
directions a try. 

1. Open Micrograde > Choose Scores from the top menu bar. 

2. Choose Import Scores > Choose User Defined… 

3. Select the Exam/Quiz that you want to import scores for from the list > Click [OK]. 

4. Navigate to the AppScan scores text 
file location > Choose the .txt file > 
Click [Open]. 

5. Select the first line that contains an 
ID# and score > Click [Continue…]. 

6. Enter the Start Byte and Length for the 
Student ID and the Score (see example 
at right). 

7. Click [OK] again > Click [Finished]. 

 

Define Grading Standards 

You can alter the standard grading scale that accompanies MicroGrade. 

1. Choose Edit > Choose Grade Standards…. 

2. Click in the left pane to highlight Class Standards.  

(Otherwise you’ll only change the grading standard for a particular category/assignment.) 

3. Alter any % Cutoffs or Grade Names as you wish.    

(This will become the grading scale for all assignments you set up.) 

 
Important!  If you alter this table, you must click [Calculate] to apply this to grades already in the 
grade book. 
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Export Final Grades to CedarInfo 

 
Create Text File in Micrograde  

1. From the top menu bar, choose File > Choose Export > then Choose General…. 

(A General Export for 
Grading Period: ___ dialog 
box will open) 

2. Choose ID from the Student:           
drop-down list. 

3. Type a comma.  

4. Choose Overall Grade from 
the Letter Grade: drop-down 
list. 

5. Choose Current class from the 
Students To Export: drop-
down list. 

6. Click [Export…]. 

7. A Choose Export File Format 
dialog box will open (see 
below). 

 

8. Click the radio button labeled                                              
General Export Format. 

9. Choose the comma option “,” from the Field Separator: 
drop-down list. 

10. Click [OK]. 

11. Navigate to H:\docs > name the file. 

12. Choose file type Text Files (.txt). 

13. Click [Save]. 

 

Upload Text File to 
CedarInfo 

14. Go to the Cedarville 
FacStaff homepage > 
Click [CedarInfo]. 

15. Log in with your 
CedarNet username 
and password. 

16. Click on CedarInfo 

17. Go to Curricular Transactions > Choose Enter final grades from text file (faculty). 

18. Enter the appropriate course data (term, subject, course, section, etc.). 

19. Type the name of the text file you created in step 13 in the above field labeled File name in your 
H:\DOCS directory: . 

20. Click [Process Grades]. 
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Make sure your filename does not contain spaces or symbols. Also be sure 
to include the .txt suffix in your filename.  
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Copy Class Files 
Backup Your Class Files and Data   

1. Open the Micrograde class file that you wish to backup. 

2. From the top menu bar, choose File > Choose Save As…. 

(The Save As Options dialog box will open.) 

3. Choose [Option 1] to create a backup of your current class. 

4. Click [Save…] > Name the file > Click [Save] again. 

 

Create a New Class without Student Data (e.g., for next semester) 

1. Open the Micrograde class file that you wish to 
copy for next semester. 

2. Choose File > Choose Save as… from the top 
menu bar. 

3. The Save As Options dialog box will open. 

4. Choose [Option 3] to create a new class. 

5. Click [Save…] > Name the file with the new 
semester info > Choose [Save]. 

6. From the top menu bar, choose Periods > 
Choose Modify Grading Period…. 

7. Type the new (upcoming) period in the 
Grading Period: field. 

8. Proceed to Export a Class Roster and Import the Class Roster. (pg. 1 and 2) 

 

  


